Centre d'aide

Explorer notre base de connaissance
article

Configurations nécessaires au bon fonctionnement d'iAdvize

 

1/ Les navigateurs compatibles

iAdvize est une application SaaS riche qui utilise de nombreuses technologies récentes. Elle nécessite donc un navigateur internet performant.

L'utilisation d'iAdvize est optimale avec les deux dernières versions de Google Chrome, Mozilla Firefox, Edge, Opera et Safari. Ces versions sont testées et approuvées par nos équipes techniques.

iAdvize peut fonctionner sur des versions antérieures (le listing est affiché ci-dessous). Cependant nous ne pouvons en garantir le bon fonctionnement de 100% de la solution.
C'est pourquoi nous ne nous engageons pas à apporter des corrections systématiques sur ces versions antérieures.

Aussi, nous vous conseillons de mettre à jour votre navigateur régulièrement.

Note : Si vous ne connaissez pas la version de votre navigateur ou comment le mettre à jour, vous trouverez de l'aide sur cette page : https://updatemybrowser.org/ 

1.1 Livechat (Côté visiteur)
Les navigateurs recommandés sont :

  • Edge, les 2 dernières versions
  • Firefox, les 2 dernières versions
  • Chrome, les 2 dernières versions
  • Safari*, la dernière version 

Les navigateurs supportés sont : 

  • Edge 15 et plus
  • Firefox 52 et plus
  • Chrome 56 et plus
  • Safari* 10.1 et plus
  • Opera 38 et plus
  • Internet Explorer 11

Note : Certaines versions de navigateur n'étant plus maintenues par leur propriétaire, elles risquent par conséquent de ne pas prendre en charge les dernières technologies web utilisées par iAdvize. C'est pourquoi cette liste de navigateurs supportés peut être amenée à évoluer.


1.2 Pupitre de discussion, Administration iAdvize, Administration Ibbü (Côté Backoffice)

Les navigateurs recommandés sont :

  • Edge, les 2 dernières versions
  • Firefox, les 2 dernières versions
  • Chrome, les 2 dernières versions
  • Safari*, la dernière version

Les navigateurs supportés sont : 

  • Edge 15 et plus
  • Firefox 52 et plus
  • Chrome 56 et plus
  • Safari* 11 et plus
  • Opera 38 et plus
  • Internet Explorer 11

Note : Certaines versions de navigateur n'étant plus maintenues par leur propriétaire, elles risquent par conséquent de ne pas prendre en charge les dernières technologies web utilisées par iAdvize. C'est pourquoi cette liste de navigateurs supportés peut être amenée à évoluer.


1.3 Mirroring / Cobrowsing (Pupitre de discussion et Superviseur)

Compatibilité côté livechat (visiteur) : 

Nous ne sommes pas en mesure de proposer le mirroring / cobrowsing au sein du pupitre de discussion et du superviseur iAdvize, si le visiteur utilise l'un de ces navigateurs :

  • Version antérieure à Android 4.4 (visiteur sur mobile)

Pour les conversations initiées avec ces visiteurs, le message "La version du navigateur utilisée par le visiteur est trop ancienne" va s'afficher.


1.4 Click-to-Call et Click-to-Video

La fonctionnalité Click-to-Call avec décrochage depuis le pupitre iAdvize et Click-to-vidéo ne sont pas compatibles avec les navigateurs Internet Explorer 11, Edge 14 et mois, Safari 10 et moins. Ces navigateurs ne supportent pas le protocole WebRTC sur lequel se base ces fonctionnalités.


2/ Configurations des navigateurs et librairies compatibles sur votre site

2.1 Le navigateur des agents et des visiteurs

  • Le Javascript doit être activé
  • Les Cookies doivent être acceptés
  • Le LocalStorage* doit être activé
  • Les Websockets doivent être acceptés

Note : Si ces configurations ne sont pas respectées, nous ne pouvons garantir le bon fonctionnement de la solution. 
la navigation privée de Safari désactive le 'localstorage', fonctionnalité nécessaire au bon fonctionnement d'iAdvize. Le chat ne pourra donc pas s'afficher.


2.2 Les librairies javascript compatibles

Malgré tous les efforts fournis par iAdvize pour minimiser ce type de conflit, certaines anciennes librairies Javascript tierces, potentiellement utilisées sur votre site, peuvent empêcher le bon chargement du tag iAdvize.
En effet, ces librairies Javascript écrasent la définition de certaines méthodes javascript natives aux navigateurs (ex : Array.prototype.toJSON) empêchant ainsi le tag iAdvize de les utiliser.

Ces incompatibilités peuvent gêner le bon fonctionnement de la solution et nuire à l'expérience utilisateur (les messages d'une conversation peuvent disparaître de la chatbox, le mirroring et le cobrowsing ne fonctionne pas...).

Les librairies Javascript tierces actuellement identifiées comme incompatibles sont : 
- prototype.js, les versions inférieures ou égale à 1.6  (http://prototypejs.org/)

Note : iAdvize ne s'engage pas à supporter à ces librairies, ni à apporter des corrections nécessaires pour les rendre compatible le tag iAdvize avec votre site.


2.3 Les iFrames

Les iframes sont utilisées pour afficher certains contenus (notifications, chatbox,...).
Il est donc nécessaire de ne pas bloquer les iframes et leur contenu (HTML, CSS, JS).


2.4 La connexion internet des agents connectés au pupitre discussion

Pour en savoir plus, nous vous invitons à consulter l'article sur la Configuration des paramètres réseau.

Note : Pour connaître la compatibilité de l'Application Mobile iAdvize, nous vous invitons à suivre cet article

Commentaires